IX2105でIPoE (IPv4 over IPv6 TransixIPv4)やってみた

 今回IX2105を安く入手することが出来たため、以前に行った「IX2215でIPoE (IPv4 over IPv6)やってみた」と同様の検証を行ってみたいと思います。
またその結果、私の環境において適切なルータはどちらなのか調べて行きたいと思います。

※この実験は、環境によって差異が生じる可能性があります。よって、同様の結果が得られない場合もございます。参考程度にご活用ください。


環境

今回の実験に利用する環境は以下の通りです。
  • ネット回線:NTT東 光配線 楽天ひかり マンション1G契約(アルテリアネットワーク クロスパス)
  • 方式:transix IPv4接続(DS-Lite)
  • ルータ:IX2105(Ver 10.2.34) ※2021-09-19時点最新 NEC公式ファームウェア
  • 測定サイト:fast.com(IPv4接続)

素材の下ごしらえ

まず、ルータを開封し状態を確認します。
今回使用するルータはこちら

ジャンク扱いで出品されていたもので、ALMに赤いランプが点灯するとのことでした。
それ以上に関しては動作未確認とのことです。
正直、コンフィグが残っている状態で何かしらのエラーを起こしているのかなぁという推測の元購入しました。

とりあえず、火入れをしてみると...

はい、見事にジャンクでした。ありがとうございます。
NVRAMのテストでFailが出ています。これは結構致命的に思えます。
一応、コンフィグの保存と再起動後のデータ保持は出来ているようでしたので、今回は見て見ぬ振りを致しました。起動さえできてしまえば、基本はRAM内で処理するはずなので、パフォーマンス等に影響はないかと思われます。(検証用にでもするかなぁ....


軽く設定を済ませた後、ファームウェアのアップデートを行います。
今回は、LAN側のIP設定のみ行い、WebUI経由で更新しました。rapファイルはNEC公式の会員サイトからダウンロードしました。

正直、NVRAMに問題があるなか、ファームウェアのアップデートを行うのはどうなんだろうという気持ちもありましたが、無事完走し、最新ファームを適応することが出来ました。


余談ですが、物理的に電源を落とさずにファームの更新でリブートをした際はALMランプが消えていました。起動時のテストを飛ばすと検知しないんですね...

そして、一度ファクトリーリセットを行い、現在利用しているIX2215のコンフィグを少し手直ししてすべて投入しました。これで準備は完了です。


検証

それではお待ちかね、検証を行っていきます。
まずfast.comの測定結果ですが、

このような値となりました。
IX2215の検証では、下り790Mbps程出ていたので、かなり落ちていることがわかります。

次に測定時のCPU/メモリの使用率を確認します。


この結果から、CPU使用率が100まで張り付いていることがわかります。
メモリは比較的余裕があるようです。
(IX2215では倍以上の速度で50%程度でした。)

まとめ

IX2105ではtransix IPv4(DSLite)接続を行うとCPUの力不足により速度が律速されてしまうことがわかりました。つまり、私の環境に最適なルータはIX2215ということになります。しかし、ある程度の速度が出ればそれで良い、安価にVLAN等が利用できるルータを導入したいといった場合には選択肢になり得るかもしれません。
今回は、transix IPv4(DSLite)というNATステートフルな接続方式ですが、MAP-EなどのNATステートレスな接続方式ではさらにCPUの処理速度が必要になるのではないかと予想されます。(どなたか環境のある方で検証された方がいらっしゃれば情報お待ちしています。)
また、私の検証方法に不明点や改善点等ありましたら、気軽にコメントいただけると幸いです。

なにかの参考になれば幸いです。









ばいち

コメント

  1. NVRAMですが、NAPHAT BATTの交換で修理可能かもしれないという話をお聞きしたので後日試してみたいと思います。情報ありがとうございます!

    返信削除

コメントを投稿